Affinity Analytics data refresh delays

Incident Report for Affinity

Resolved

We have successfully processed the backlog. This incident is now fully resolved.
Posted Jun 24, 2025 - 07:34 PDT

Update

We continue to monitor and process the backlog.
Posted Jun 23, 2025 - 19:39 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 23, 2025 - 15:19 PDT

Monitoring

We are currently experiencing data delays affecting Affinity Analytics. We are still processing the backlog and we will provide an update in 3 hours.
Posted Jun 23, 2025 - 12:14 PDT
This incident affected: Analytics.