Microsoft 365 processing delays
Incident Report for Affinity
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 06:56 PST
Update
Microsoft's Exchange Online services have been restored. We are now addressing the backlog, which we estimate will take a few hours to process. Our engineering team is closely monitoring the progress.

Thank you for your patience and understanding. We will share another update either when the issue is fully resolved or within the next 12 hours.
Posted Nov 27, 2024 - 07:19 PST
Monitoring
Affinity customers who use Microsoft Office 365 may experience delays in syncing email and calendar activity into Affinity as a result of an ongoing service disruption with Microsoft's Exchange Online services.
Microsoft customers can find more information about the disruption within their Microsoft admin center.
Posted Nov 26, 2024 - 06:27 PST
This incident affected: Processing Pipelines (Emails Processing, Calendars Processing).