Email and Calendar Processing Delays

Incident Report for Affinity

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 11:04 PST

Monitoring

A fix has been implemented and we are monitoring progress of processing the backlog.
Posted Dec 18, 2025 - 02:19 PST

Investigating

We've identified an issue with our email and calendar processing pipelines resulting in delays in seeing up to date information in the application.
Posted Dec 17, 2025 - 15:32 PST
This incident affected: Processing Pipelines (Emails Processing, Calendars Processing).