We continue to process through the backlog to reduce delays and are actively monitoring.
Posted Apr 10, 2025 - 15:07 PDT
Identified
Microsoft Office 365 users may be experiencing delays in syncing email and calendar activity into Affinity. Our team is actively investigating the issue, affected customers may see delays of up to 2 hours.
Posted Apr 10, 2025 - 12:49 PDT
This incident affected: Processing Pipelines (Emails Processing, Calendars Processing).