We are seeing signs of recovery and are actively monitoring all services. We will post another update once we can confirm the issue is fully resolved.
Posted Sep 03, 2026 - 15:35 PDT
Identified
Users may be experiencing errors or an inability to access the service due to an issue with our cloud service provider. We will provide another update within 60 minutes.
Posted Sep 03, 2026 - 15:15 PDT
This incident affected: CRM, Analytics, Affinity for Salesforce, Integrations, MCP, Affinity API (External API v1, External API v2, API Documentation), Processing Pipelines (Emails Processing, Calendars Processing, Data Enrichment), Mobile Application (iOS, Android), and Extensions (Chrome Extension, Affinity for Outlook).