Affinity Analytics dashboards are showing no data

Incident Report for Affinity

Resolved

All Affinity Analytics dashboards, including Company-related reports, are now fully restored. Data is available across all reports, and the system is stable.

Thanks for your patience while we worked through the issue!
Posted Jul 20, 2025 - 09:37 PDT

Monitoring

Most Affinity Analytics dashboards are now showing data again. However, Company-related reports are still unavailable for some customers. We're actively working on restoring those and continuing to monitor the system.

Thanks for your patience - we’ll share another update as soon as full access is restored.
Posted Jul 20, 2025 - 04:53 PDT

Identified

All Dashboards in Affinity Analytics are currently missing data. We have identified the issue and are working on restoring the access to the data.
Posted Jul 19, 2025 - 11:45 PDT
This incident affected: Analytics.