Support Live Chat is unavailable
Incident Report for Affinity
Resolved
This incident has been resolved
Posted Aug 11, 2023 - 08:42 PDT
Identified
We have identified the issue and actively working with the vendor on the resolution. Meanwhile, if you need to reach us, please email to support@affinity.co
Posted Aug 10, 2023 - 17:58 PDT
Investigating
Our Support Live Chat is currently unavailable. We are aware and currently working with the vendor on a resolution. Good news, everything else is fully functional but if you'd like to reach us, you may still do so via Email.
Posted Aug 10, 2023 - 15:38 PDT