Affinity Availability Impaired
Incident Report for Affinity
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 19:51 PDT
Update
At approximately 16:30 PDT we re-enabled Affinity Pathfinder, Affinity for Gmail, the Connections side panel, and background email & calendar sync.

At present, Affinity systems are operating normally, however it may take some time for some services to synchronize with external email accounts.

We will continue to carefully monitor the stability of our downstream services partner (AWS) and will wait to declare today's issue fully "stable" until we are confident in their stability.

Thank you for your patience.
Posted Aug 31, 2021 - 16:15 PDT
Update
We are continuing to see stability across most product usage.

A few pieces of functionality are still disabled, including Affinity Pathfinder, Affinity for Gmail, and the Connections side panel. In addition, background processes such as email syncing are temporarily paused.

We are continuing to monitor the issue while we work towards a full restoration of service.
Posted Aug 31, 2021 - 13:07 PDT
Update
We are continuing to monitor the issue and are still aware of degraded performance in certain bits of functionality, including login flows (intermittently), Affinity for Gmail, and Affinity Pathfinder. We believe that most functionality in the web app should be somewhat stable with intermittent failures and are continuing to work on further improvements and upstream mitigations.
Posted Aug 31, 2021 - 12:38 PDT
Update
Our fix has successfully restored functionality to the Affinity web app, but users may still experience degraded performance. However, the Affinity Pathfinder and Gmail Extensions are currently unavailable as a result of our fix, and users will notice syncing delays.

As a result of our investigation, we have determined that the External API, Affinity Analytics, and Affinity Integrations were likely not affected. We will continue to monitor the issue and send additional updates as we have them.
Posted Aug 31, 2021 - 12:19 PDT
Monitoring
We've currently implemented a fix that should restore partial functionality to the Affinity app. However, some Affinity functionality is still unavailable. We're continuing to work on improvements to mitigate the upstream issue and will share more details here as we have them.
Posted Aug 31, 2021 - 12:08 PDT
Update
We're continuing to monitor the upstream issue and actively working on partial fixes that may restore some functionality. We will continue sharing more information here as we obtain them.
Posted Aug 31, 2021 - 11:59 PDT
Identified
We've identified the issue as an upstream issue with our service provider (Amazon AWS) in our server region. We're currently monitoring the upstream issue, working on possible fixes, and will keep this page updated as the status changes.
Posted Aug 31, 2021 - 11:35 PDT
Investigating
We're aware of issues receiving 503 errors while connecting to Affinity. We're currently aware of the issue and actively investigating, and will update this page when we have more information.
Posted Aug 31, 2021 - 11:30 PDT
This incident affected: Web Application, API, Analytics, and Integrations.